DisplayColorGradient Class |
Namespace: Grasshopper.Rhinoceros.Display
The DisplayColorGradient type exposes the following members.
Name | Description | |
---|---|---|
![]() | DisplayColorGradient |
Blank constructor
|
![]() | DisplayColorGradient(ColorGradient) | Initializes a new instance of the DisplayColorGradient class |
![]() | DisplayColorGradient(DisplayColorGradient) | Initializes a new instance of the DisplayColorGradient class |
Name | Description | |
---|---|---|
![]() | ClippingBox | |
![]() | IsValid |
Gets the validity of this instance.
(Overrides GH_GooTIsValid.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
![]() | Value |
Gets or sets the internal data.
(Inherited from GH_GooT.) |
Name | Description | |
---|---|---|
![]() | CastFrom | (Overrides GH_GooTCastFrom(Object).) |
![]() | CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) |
![]() | CastToT(T) | (Overrides GH_GooTCastToQ(Q).) |
![]() | DrawViewportMeshes | |
![]() | DrawViewportWires | |
![]() | Duplicate | (Overrides GH_GooTDuplicate.) |
![]() | DuplicateColourGradient | |
![]() | EmitProxy |
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Inherited from GH_GooT.) |
![]() | Read | (Overrides GH_GooTRead(GH_IReader).) |
![]() | ScriptVariable |
This function will be called when the local IGH_Goo instance
disappears into a user Script. This would be an excellent place to
cast your IGH_Goo type to a simple data type.
(Inherited from GH_GooT.) |
![]() | ToString | (Overrides GH_GooTToString.) |
![]() | Write | (Overrides GH_GooTWrite(GH_IWriter).) |