Click or drag to resize

DisplayColorStop Class

Represents a gradient colour stop. Wraps the functionality of the ColorStop type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooColorStop
    Grasshopper.Rhinoceros.DisplayDisplayColorStop

Namespace:  Grasshopper.Rhinoceros.Display
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class DisplayColorStop : GH_Goo<ColorStop>

The DisplayColorStop type exposes the following members.

Constructors
  NameDescription
Public methodDisplayColorStop
Blank constructor
Public methodDisplayColorStop(ColorStop)
Initializes a new instance of the DisplayColorStop class
Public methodDisplayColorStop(DisplayColorStop)
Initializes a new instance of the DisplayColorStop class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance.
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateColorStop
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also