Click or drag to resize

ModelValue Class

Represents a value in a Rhino model.
Inheritance Hierarchy
SystemObject
  Grasshopper.RhinocerosModelValue
    More...

Namespace:  Grasshopper.Rhinoceros
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class ModelValue : IGH_ModelData, 
	ICloneable, IEquatable<ModelValue>

The ModelValue type exposes the following members.

Constructors
  NameDescription
Protected methodModelValue
Initializes a new instance of the ModelValue class
Top
Properties
Methods
Remarks
This type is the base type of a family of immutable types.
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.RhinocerosModelValue
    Grasshopper.Rhinoceros.DisplayObjectDisplay
    Grasshopper.Rhinoceros.DisplayObjectDisplayColor
    Grasshopper.Rhinoceros.DisplayObjectVisibility
    Grasshopper.Rhinoceros.DraftingModelHatchLine
    Grasshopper.Rhinoceros.DraftingObjectDrafting
    Grasshopper.Rhinoceros.DraftingObjectDraftingColor
    Grasshopper.Rhinoceros.DraftingObjectDraftingLinetype
    Grasshopper.Rhinoceros.DraftingObjectDraftingLineWidth
    Grasshopper.RhinocerosModelMeshingParameters
    Grasshopper.RhinocerosModelUnitSystem
    Grasshopper.Rhinoceros.RenderObjectRender
    Grasshopper.Rhinoceros.RenderObjectRenderMaterial