Click or drag to resize

ModelEarthAnchorPoint Class

Represents a Rhino Earth anchor point. Wraps the functionality of the EarthAnchorPoint type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Model
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelEarthAnchorPoint : ModelContent, 
	IGH_BakeAwareData

The ModelEarthAnchorPoint type exposes the following members.

Constructors
  NameDescription
Public methodModelEarthAnchorPoint
Initializes a new instance of the ModelEarthAnchorPoint class
Public methodModelEarthAnchorPoint(ModelEarthAnchorPointAttributes)
Initializes a new instance of the ModelEarthAnchorPoint class
Public methodModelEarthAnchorPoint(EarthAnchorPoint)
Initializes a new instance of the ModelEarthAnchorPoint class
Top
Properties
  NameDescription
Public propertyElevation
Gets a point elevation on earth, in meters.
Public propertyElevationCoordinateSystem
Gets the value indicating the zero level convention relating to a location on Earth
Public propertyLatitude
Gets a point latitude on earth, in degrees. +90 = north pole, 0 = equator, -90 = south pole.
Public propertyLongitude
Gets a point longitude on earth, in degrees.
Public propertyModelCompass
Gets the corresponding compass plane in model coordinates
Public propertySphereUParameter
Gets the spherical U parameter.
Public propertySphereVParameter
Gets the spherical V parameter.
Top
Methods
  NameDescription
Public methodStatic memberCast
Public methodCastToT(T) (Overrides ModelContentCastToT(T).)
Public methodToAttributes
Public methodTooltipString (Overrides ModelContentTooltipString.)
Public methodToString (Overrides ModelContentToString.)
Top
Operators
See Also