Description:

Constructs a new instance of ColorHSL that is equivalent to an ARGB color.

Syntax:
public ColorHSL(
Color rgb
)
Parameters:
  • rgb
  • Type: System.Drawing.Color
  • ARGB color to mimic.
Remarks:
Exact conversions between color spaces are often not possible.
Available since:
5.0

Description:

Constructs a new instance of ColorHSL with custom channel values.

Syntax:
public ColorHSL(
double alpha,
double hue,
double saturation,
double luminance
)
Parameters:
  • alpha
  • Type: double
  • Alpha channel value. Channel will be limited to 0~1.
  • hue
  • Type: double
  • Hue channel value. Hue channels rotate between 0.0 and 1.0.
  • saturation
  • Type: double
  • Saturation channel value. Channel will be limited to 0~1.
  • luminance
  • Type: double
  • Luminance channel value. Channel will be limited to 0~1.
Available since:
5.0

Description:

Constructs a new instance of ColorHSL with custom channel values.

Syntax:
public ColorHSL(
double hue,
double saturation,
double luminance
)
Parameters:
  • hue
  • Type: double
  • Hue channel value. Hue channels rotate between 0.0 and 1.0.
  • saturation
  • Type: double
  • Saturation channel value. Channel will be limited to 0~1.
  • luminance
  • Type: double
  • Luminance channel value. Channel will be limited to 0~1.
Available since:
5.0

ColorHSL constructor

Class:  Rhino.Display.ColorHSL

Nothing found