Description:

Constructs a DisplayBitmap from an existing bitmap.

Syntax:
public DisplayBitmap(
Bitmap bitmap
)
Parameters:
  • bitmap
  • Type: System.Drawing.Bitmap
  • The original bitmap.
Available since:
5.0

Description:

Creates a DisplayBitmap either from a path, or a bitmap. If the path is null, a random tag name will be used. If the bitmap is null, the bitmap will be loaded from the path. If both are null, the object is invalid. if both are valid objects, the bitmap will be used and it will be added to Rhino's bitmap cache with the path supplied. In other words, this is a way to add a bitmap from memory directly into Rhino's memory cache.

Syntax:
public DisplayBitmap(
string path,
Bitmap bitmap
)
Parameters:
  • path
  • Type: string
  • If null, use a temporary tag name. If non-null, use that path in Rhino's bitmap cache. Note, this version does not support URLs.
  • bitmap
  • Type: System.Drawing.Bitmap
  • If null, load the bitmap from the supplied path. If non-null, creates the bitmap from the data supplied.
Available since:
7.16

DisplayBitmap constructor

Class:  Rhino.Display.DisplayBitmap

Nothing found