Description:

Constructs a default material.

Syntax:
public DisplayMaterial()
Available since:
5.0

Description:

Constructs a material with custom properties.

Syntax:
public DisplayMaterial(
Color diffuse,
Color specular,
Color ambient,
Color emission,
double shine,
double transparency
)
Parameters:
  • diffuse
  • Type: Color
  • Diffuse color of material. The alpha component of the Diffuse color is ignored.
  • specular
  • Type: Color
  • Specular color of material. The alpha component of the Specular color is ignored.
  • ambient
  • Type: Color
  • Ambient color of material. The alpha component of the Ambient color is ignored.
  • emission
  • Type: Color
  • Emission color of material. The alpha component of the Emission color is ignored.
  • shine
  • Type: double
  • Shine (highlight size) of material.
  • transparency
  • Type: double
  • Transparency of material (0.0 = opaque, 1.0 = transparent)
Available since:
5.0

Description:

Constructs a default material with a specific diffuse color and transparency.

Syntax:
public DisplayMaterial(
Color diffuse,
double transparency
)
Parameters:
  • diffuse
  • Type: Color
  • Diffuse color of material. The alpha component of the Diffuse color is ignored.
  • transparency
  • Type: double
  • Transparency factor (0.0 = opaque, 1.0 = transparent)
Available since:
5.0

Description:

Constructs a default material with a specific diffuse color.

Syntax:
public DisplayMaterial(
Color diffuse
)
Parameters:
  • diffuse
  • Type: Color
  • Diffuse color of material. The alpha component of the Diffuse color is ignored.
Available since:
5.0

Description:

Duplicate another material.

Syntax:
public DisplayMaterial(
DisplayMaterial other
)
Available since:
5.0

Description:
Syntax:
public DisplayMaterial(
Material material
)
Available since:
5.0

DisplayMaterial constructor

Class:  Rhino.Display.DisplayMaterial

Nothing found