Description:

Finds the instance definition with a given name.

Syntax:
public InstanceDefinition Find(
string instanceDefinitionName,
bool ignoreDeletedInstanceDefinitions
)
deprecated in 6.0
obsolete: ignoreDeletedInstanceDefinitions is now redundant. Remove the second argument. Definitions are now always deleted permanently.
Parameters:
  • instanceDefinitionName
  • Type: string
  • name of instance definition to search for (ignores case)
  • ignoreDeletedInstanceDefinitions
  • Type: bool
  • True means don't search deleted instance definitions.
Returns:
The specified instance definition, or None if nothing matching was found.
Available since:
5.0

Description:

Finds the instance definition with a given name.

Syntax:
public InstanceDefinition Find(
string instanceDefinitionName
)
Parameters:
  • instanceDefinitionName
  • Type: string
  • name of instance definition to search for (ignores case)
Returns:
The specified instance definition, or None if nothing matching was found.
Available since:
6.0

Description:

Finds the instance definition with a given id.

Syntax:
public InstanceDefinition Find(
Guid instanceId,
bool ignoreDeletedInstanceDefinitions
)
Parameters:
  • instanceId
  • Type: System.Guid
  • Unique id of the instance definition to search for.
  • ignoreDeletedInstanceDefinitions
  • Type: bool
  • True means don't search deleted instance definitions.
Returns:
The specified instance definition, or None if nothing matching was found.
Available since:
5.0

Nothing found