Description:

Checks the dictionary for the specified key, if found and the value is not None then the value is returned. If the key is not found or its value is None then newT(Document) is called to create a new value instance which is put in the dictionary and returned.

Syntax:
public T GetValue(
object key,
Func<RhinoDoc, T> newT
)
Parameters:
  • key
  • Type: object
  • Key to search for.
  • newT
  • Type: Func<RhinoDoc, T>
  • Function called to create new value
Returns:
Type: T
Returns the document specific instance of type T using the specified dictionary key.

Nothing found