Description:

Constructs a flow space morph.

Syntax:
public SplopSpaceMorph(
Plane plane,
Surface surface,
Point2d surfaceParam,
double scale,
double angle
)
Parameters:
  • plane
  • Type: Plane
  • Source plane of deformation.
  • surface
  • Type: Surface
  • Surface to wrap objects onto.
  • surfaceParam
  • Type: Point2d
  • U,V parameter on surface used for orienting.
  • scale
  • Type: double
  • Scale factor. To ignore, use Rhino.RhinoMath.UnsetValue.
  • angle
  • Type: double
  • Rotation angle in radians. To ignore, use Rhino.RhinoMath.UnsetValue.
Available since:
5.9

Description:

Constructs a flow space morph.

Syntax:
public SplopSpaceMorph(
Plane plane,
Surface surface,
Point2d surfaceParam,
double scale
)
Parameters:
  • plane
  • Type: Plane
  • Source plane of deformation.
  • surface
  • Type: Surface
  • Surface to wrap objects onto.
  • surfaceParam
  • Type: Point2d
  • U,V parameter on surface used for orienting.
  • scale
  • Type: double
  • Scale factor.
Available since:
5.9

Description:

Constructs a flow space morph.

Syntax:
public SplopSpaceMorph(
Plane plane,
Surface surface,
Point2d surfaceParam
)
Parameters:
  • plane
  • Type: Plane
  • Source plane of deformation.
  • surface
  • Type: Surface
  • Surface to wrap objects onto.
  • surfaceParam
  • Type: Point2d
  • U,V parameter on surface used for orienting.
Available since:
5.9

SplopSpaceMorph constructor

Class:  Rhino.Geometry.Morphs.SplopSpaceMorph

Nothing found