Description:

Constructs a taper space morph.

Syntax:
public TaperSpaceMorph(
Point3d start,
Point3d end,
double startRadius,
double endRadius,
bool bFlat,
bool infiniteTaper
)
Parameters:
  • start
  • Type: Point3d
  • Start of the taper axis.
  • end
  • Type: Point3d
  • End of the taper axis.
  • startRadius
  • Type: double
  • Radius at start point.
  • endRadius
  • Type: double
  • Radius at end point.
  • bFlat
  • Type: bool
  • If true, then a one-directional, one-dimensional taper is created.
  • infiniteTaper
  • Type: bool
  • If false, the deformation takes place only the length of the axis. If true, the deformation happens throughout the object, even if the axis is shorter.
Available since:
5.9

TaperSpaceMorph constructor

Class:  Rhino.Geometry.Morphs.TaperSpaceMorph

Nothing found