Description:

Initializes a new instance of Point2d from coordinates.

Syntax:
public Point2d(
double x,
double y
)
Parameters:
  • x
  • Type: double
  • The X (first) coordinate.
  • y
  • Type: double
  • The Y (second) coordinate.
Available since:
5.0

Description:

Initializes a new instance of Point2d by copying another Point2d .

Syntax:
public Point2d(
Point2d point
)
Parameters:
  • point
  • Type: Point2d
  • The point that will be copied.
Available since:
5.0

Description:

Initializes a new instance of Point3d by copying the first two coordinates of a Point3d .

Syntax:
public Point2d(
Point3d point
)
Parameters:
  • point
  • Type: Point3d
  • The point that will be used: the Z (third) coordinate is discarded.
Available since:
5.0

Description:

Initializes a new instance of Point2d by converting a vector.

Syntax:
public Point2d(
Vector2d vector
)
Parameters:
  • vector
  • Type: Vector2d
  • The vector that will be copied.
Available since:
5.0

Point2d constructor

Class:  Rhino.Geometry.Point2d

Nothing found