Description:
Syntax:
public bool PickFrustumTest(
BezierCurve bezier,
out double t,
out double depth,
out double distance
)
Returns:
Type: bool
Available since:
5.0

Description:

Fast test to check if a bounding box intersects a pick frustum.

Syntax:
public bool PickFrustumTest(
BoundingBox box,
out bool boxCompletelyInFrustum
)
Parameters:
  • boxCompletelyInFrustum
  • Type: bool
  • Set to True if the box is completely contained in the pick frustum. When doing a window or crossing pick, you can immediately return a hit if the object's bounding box is completely inside of the pick frustum.
Returns:
Type: bool
False if bounding box is invalid or box does not intersect the pick frustum
Available since:
5.0

Description:
Syntax:
public bool PickFrustumTest(
Line line,
out double t,
out double depth,
out double distance
)
Returns:
Type: bool
Available since:
5.0

Description:

Utility for picking meshes

Syntax:
public bool PickFrustumTest(
Mesh mesh,
MeshPickStyle pickStyle,
out Point3d hitPoint,
out double depth,
out double distance,
out MeshHitFlag hitFlag,
out int hitIndex
)
Parameters:
  • depth
  • Type: double
  • depth returned here for point picks LARGER values are NEARER to the camera. SMALLER values are FARTHER from the camera.
  • distance
  • Type: double
  • planar distance returned here for point picks. SMALLER values are CLOSER to the pick point
  • hitFlag
  • Type: MeshHitFlag
  • For point picks, How to interpret the hitIndex (vertex hit, edge hit, or face hit)
  • hitIndex
  • Type: int
  • index of vertex/edge/face that was hit. Use hitFlag to determine what this index corresponds to
Returns:
Type: bool
Available since:
5.0

Description:

Utility for picking meshes

Syntax:
public bool PickFrustumTest(
Mesh mesh,
MeshPickStyle pickStyle,
out Point3d hitPoint,
out Point2d hitSurfaceUV,
out Point2d hitTextureCoordinate,
out double depth,
out double distance,
out MeshHitFlag hitFlag,
out int hitIndex
)
Parameters:
  • hitSurfaceUV
  • Type: Geometry.Point2d
  • If the mesh has surface parameters, set to the surface parameters of the hit point
  • hitTextureCoordinate
  • Type: Geometry.Point2d
  • If the mesh has texture coordinates, set to the texture coordinate of the hit point. Note that the texture coordinates can be set in many different ways and this information is useless unless you know how the texture coordinates are set on this particular mesh.
  • depth
  • Type: double
  • depth returned here for point picks LARGER values are NEARER to the camera. SMALLER values are FARTHER from the camera.
  • distance
  • Type: double
  • planar distance returned here for point picks. SMALLER values are CLOSER to the pick point
  • hitFlag
  • Type: MeshHitFlag
  • For point picks, How to interpret the hitIndex (vertex hit, edge hit, or face hit)
  • hitIndex
  • Type: int
  • index of vertex/edge/face that was hit. Use hitFlag to determine what this index corresponds to
Returns:
Type: bool
Available since:
5.0

Description:
Syntax:
public bool PickFrustumTest(
NurbsCurve curve,
out double t,
out double depth,
out double distance
)
Returns:
Type: bool
Available since:
5.0

Description:

Utility for picking 3d point

Syntax:
public bool PickFrustumTest(
Point3d point,
out double depth,
out double distance
)
Parameters:
  • depth
  • Type: double
  • depth returned here for point picks. LARGER values are NEARER to the camera. SMALLER values are FARTHER from the camera.
  • distance
  • Type: double
  • planar distance returned here for point picks. SMALLER values are CLOSER to the pick point
Returns:
Type: bool
True if there is a hit
Available since:
5.0

Description:
Syntax:
public bool PickFrustumTest(
Point3d[] points,
out int pointIndex,
out double depth,
out double distance
)
Returns:
Type: bool
Available since:
5.0

Description:
Syntax:
public bool PickFrustumTest(
PointCloud cloud,
out int pointIndex,
out double depth,
out double distance
)
Returns:
Type: bool
Available since:
5.0

PickFrustumTest method

Class:  Rhino.Input.Custom.PickContext

Nothing found