Description:

Runtime access to specific parameters on for a given objectId relating to this primitive provider.

Syntax:
public virtual object GetParameter(
RhinoDoc doc,
Guid objectId,
String parameterName
)
virtual
Parameters:
  • doc
  • Type: RhinoDoc
  • The Rhino document of interest.
  • objectId
  • Type: System.Guid
  • The objectId for which the parameter should be supplied.
  • parameterName
  • Type: System.String
  • The name of the parameter.
Returns:
Type: object
The value of the parameter for the specified ObjectId. IConvertable.
Available since:
8.0

Nothing found