Description:

Save doc as a 3dm to a specified path

Syntax:
public bool SaveAs(
string file3dmPath,
int version,
bool saveSmall,
bool saveTextures,
bool saveGeometryOnly,
bool savePluginData
)
Parameters:
  • version
  • Type: int
  • Rhino file version
  • saveSmall
  • Type: bool
  • whether to inlcude render meshes and preview image
  • saveTextures
  • Type: bool
  • whether to include the bitmap table
  • saveGeometryOnly
  • Type: bool
  • whether to write enything besides geometry
  • savePluginData
  • Type: bool
  • whether to write plugin user data
Returns:
Type: bool
True on success
Available since:
8.0

Description:

Save doc as a 3dm to a specified path

Syntax:
public bool SaveAs(
string file3dmPath,
int version
)
Parameters:
  • version
  • Type: int
  • Rhino file version
Returns:
Type: bool
True on success
Available since:
7.0

Description:

Save doc as a 3dm to a specified path using the current Rhino file version

Syntax:
public bool SaveAs(
string file3dmPath
)
Returns:
Type: bool
True on success
Available since:
7.0

SaveAs method

Class:  Rhino.RhinoDoc

Nothing found