Description:

Called by GetLicense to ensure that the license key entered by the user is legitimate and can be used.

Syntax:
public ValidateResult VerifyLicenseKey(
string licenseKey,
string validationCode,
DateTime validationCodeInstallDate,
bool gracePeriodExpired,
out LicenseData licenseData
)
Parameters:
  • licenseKey
  • Type: string
  • License key string entered by user
  • validationCode
  • Type: string
  • Validation code entered by user (only if a previous call to VerifyLicenseKey set LicenseData.RequiresOnlineValidation to true).
  • validationCodeInstallDate
  • Type: System.DateTime
  • Date that validation code was entered by user (only if a previous call to VerifyLicenseKey set LicenseData.RequiresOnlineValidation to true).
  • gracePeriodExpired
  • Type: bool
  • Date by which license validation must complete successfully.
  • licenseData
  • Type: LicenseData
  • Output parameter where return data about the license is set.
Returns:
Available since:
6.0

VerifyLicenseKey method

Class:  Rhino.Runtime.ZooClientParameters

Nothing found