Description:

Starts, or shows, Rhino's status bar progress meter.

Syntax:
public static int ShowProgressMeter(
int lowerLimit,
int upperLimit,
string label,
bool embedLabel,
bool showPercentComplete
)
Parameters:
  • lowerLimit
  • Type: int
  • The lower limit of the progress meter's range.
  • upperLimit
  • Type: int
  • The upper limit of the progress meter's range.
  • label
  • Type: string
  • The short description of the progress (e.g. "Calculating", "Meshing", etc)
  • embedLabel
  • Type: bool
  • If true, then the label will be embedded in the progress meter. If false, then the label will appear to the left of the progress meter.
  • showPercentComplete
  • Type: bool
  • If true, then the percent complete will appear in the progress meter.
Returns:
Type: int
1 - The progress meter was created successfully. 0 - The progress meter was not created. -1 - The progress meter was not created because some other process has already created it.
Available since:
5.0

Description:

Starts, or shows, Rhino's status bar progress meter.

Syntax:
public static int ShowProgressMeter(
uint docSerialNumber,
int lowerLimit,
int upperLimit,
string label,
bool embedLabel,
bool showPercentComplete
)
Parameters:
  • docSerialNumber
  • Type: uint
  • The document runtime serial number.
  • lowerLimit
  • Type: int
  • The lower limit of the progress meter's range.
  • upperLimit
  • Type: int
  • The upper limit of the progress meter's range.
  • label
  • Type: string
  • The short description of the progress (e.g. "Calculating", "Meshing", etc)
  • embedLabel
  • Type: bool
  • If true, then the label will be embedded in the progress meter. If false, then the label will appear to the left of the progress meter.
  • showPercentComplete
  • Type: bool
  • If true, then the percent complete will appear in the progress meter.
Returns:
Type: int
1 - The progress meter was created successfully. 0 - The progress meter was not created. -1 - The progress meter was not created because some other process has already created it.
Available since:
6.12

/
/
/
ShowProgressMeter

ShowProgressMeter method

Class:  Rhino.UI.StatusBar

Nothing found