Description:

Sets the current position of Rhino's status bar progress meter.

Syntax:
public static int UpdateProgressMeter(
int position,
bool absolute
)
Parameters:
  • position
  • Type: int
  • The new value. This can be stated in absolute terms, or relative compared to the current position. The interval bounds are specified when you first show the bar.
  • absolute
  • Type: bool
  • If true, then the progress meter is moved to position. If false, then the progress meter is moved position from the current position (relative).
Returns:
Type: int
The previous position if successful.
Available since:
5.0

Description:

Sets the label and current position of Rhino's status bar progress meter.

Syntax:
public static int UpdateProgressMeter(
string label,
int position,
bool absolute
)
Parameters:
  • label
  • Type: string
  • The short description of the progress (e.g. "Calculating", "Meshing", etc)
  • position
  • Type: int
  • The new value. This can be stated in absolute terms, or relative compared to the current position. The interval bounds are specified when you first show the bar. Note, if value is RhinoMath.UnsetIntIndex , only the label is updated.
  • absolute
  • Type: bool
  • If true, then the progress meter is moved to position. If false, then the progress meter is moved position from the current position (relative).
Returns:
Type: int
The previous position if successful.
Available since:
8.6

Description:

Sets the current position of Rhino's status bar progress meter.

Syntax:
public static int UpdateProgressMeter(
uint docSerialNumber,
int position,
bool absolute
)
Parameters:
  • docSerialNumber
  • Type: uint
  • The document runtime serial number.
  • position
  • Type: int
  • The new value. This can be stated in absolute terms, or relative compared to the current position. The interval bounds are specified when you first show the bar.
  • absolute
  • Type: bool
  • If true, then the progress meter is moved to position. If false, then the progress meter is moved position from the current position (relative).
Returns:
Type: int
The previous position if successful.
Available since:
6.12

Description:

Sets the label and current position of Rhino's status bar progress meter.

Syntax:
public static int UpdateProgressMeter(
uint docSerialNumber,
string label,
int position,
bool absolute
)
Parameters:
  • docSerialNumber
  • Type: uint
  • The document runtime serial number.
  • label
  • Type: string
  • The short description of the progress (e.g. "Calculating", "Meshing", etc)
  • position
  • Type: int
  • The new value. This can be stated in absolute terms, or relative compared to the current position. The interval bounds are specified when you first show the bar. Note, if value is RhinoMath.UnsetIntIndex , only the label is updated.
  • absolute
  • Type: bool
  • If true, then the progress meter is moved to position. If false, then the progress meter is moved position from the current position (relative).
Returns:
Type: int
The previous position if successful.
Available since:
8.6

/
/
/
UpdateProgressMeter

UpdateProgressMeter method

Class:  Rhino.UI.StatusBar

Nothing found