Returns or sets the description of a block definition.
Rhino.BlockDescription (strBlock [, strText])
strBlock |
Required. String. The name or identifier of an existing block definition. |
strText |
Optional. String. The new description. If omitted, the current description is returned. |
String |
If a description is not specified, the current description if successful. |
String |
If a description is specified, the previous description if successful. |
Null |
If not successful, or on error. |
Dim strBlock, strDesc
strBlock = Rhino.GetString("Block name to list description")
If Rhino.IsBlock(strBlock) Then
strDesc = Rhino.BlockDescription(strBlock)
If IsNull(strDesc) Then
Rhino.Print "No description"
Else
Rhino.Print strDesc
End If
End If