BlockIds

Returns the identifiers of all block definitions in the document.

Syntax

Rhino.BlockIds ()

Parameters

None.

Returns

Array

An array of block definition identifiers if successful.

Null

If not successful, or on error.

Example

Dim arrBlocks, strBlock

arrBlocks = Rhino.BlockIds

If IsArray(arrBlocks) Then

  For Each strBlock In arrBlocks

    Call Rhino.Print(strBlock)

    Call Rhino.Print(Rhino.BlockName(strBlock))

  Next

End If

Also See

BlockCount

BlockNames

IsBlock