BlockInstanceName

Returns the block definition name of a block instance object.

Syntax

Rhino.BlockInstanceName (strObject)

Parameters

strObject

Required.  String.  The identifier of an existing block instance object.

Returns

String

The block definition name if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select block")

If Rhino.IsBlockInstance(strObject) Then

 Call Rhino.Print(Rhino.BlockInstanceName(strObject))

End If

Also See

BlockInstanceCount

BlockInstanceId

BlockInstances

BlockInstanceXform

IsBlockInstance