Returns the identifiers of the inserted instances of a block.
Rhino.BlockInstances (strBlock)
strBlock |
RRequired. String. The name or identifier of an existing block definition. |
Array |
An array of strings identifying the instances of a block if successful. |
Null |
If not successful, or on error. |
Dim strBlock, arrObjects
strBlock = Rhino.GetString("Block to select")
If Rhino.IsBlock(strBlock) Then
arrObjects = Rhino.BlockInstances(strBlock)
If IsArray(arrObjects) Then
Rhino.SelectObjects arrObjects
End If
End If