BlockName

Returns the name of a block definition given the block definition's identifier.

Syntax

Rhino.BlockName (strBlock)

Parameters

strBlock

Required.  String.  The identifier of an existing block definition.

Returns

String

The  block definition's name if successful.

Null

If not successful, or on error.

Example

Dim arrBlocks, strBlock

arrBlocks = Rhino.BlockIds

If IsArray(arrBlocks) Then

  For Each strBlock In arrBlocks

    Call Rhino.Print(strBlock)

    Call Rhino.Print(Rhino.BlockName(strBlock))

  Next

End If

Also See

BlockIds

BlockInstanceId