Returns the path to the source of a linked or embedded block definition. A linked or embedded block definition is a block definition that was inserted from an external file.
Rhino.BlockPath (strBlock)
strBlock |
Required. String. The name or identifier of an existing block definition. |
String |
The path to the linked block file is successful. |
Null |
If not successful, or on error. |
Dim strBlock
strBlock = Rhino.GetString("Block name to list path")
If Rhino.IsBlockEmbedded(strBlock) Then
Rhino.Print Rhino.BlockPath(strBlock)
End If