BlockStatus
Returns the status of a linked block.
Syntax
Rhino.BlockStatus (strBlock)
Parameters
strBlock |
Required. String. The name
of an existing block definition. |
Returns
Number |
The current status.
Value |
Description |
-3 |
Not a linked block definition. |
-2 |
The linked block definition's file
could not be opened or could not be read. |
-1 |
The linked block definition's file
could not be found. |
0 |
The linked block definition is
up-to-date. |
1 |
The linked block definition's file
is newer than definition. |
2 |
The linked block definition's file
is older than definition. |
3 |
The linked block definition's file
is different than definition. |
|
Example
Dim strBlock, strDesc
strBlock = Rhino.GetString("Block
name to list description")
If Rhino.IsBlock(strBlock) Then
strDesc = Rhino.BlockDescription(strBlock)
If IsNull(strDesc) Then
Rhino.Print "No description"
Else
Rhino.Print strDesc
End If
End If
Also See
BlockURL
BlockURLTag
IsBlock