IsBlockObject

Verifies that an object is a block definition object.

Syntax

Rhino.IsBlockObject (strObject)

Parameters

strObject

Required.  String.  The identifier of an existing object.

Returns

Boolean

True or false indicating success or failure.

Null

On error.

Example

Dim arrObjects, strObject

arrObjects = Rhino.AllObjects

For Each strObject in arrObjects

  If Rhino.IsBlockObject(strObject) Then

  Rhino.Print strObject & " is block definition geometry."

  End If

Next

Also See

BlockObjectCount

BlockObjects