BlockObjects

Returns the identifiers of the objects that make up a block definition.

Syntax

Rhino.BlockObjects (strBlock)

Parameters

strBlock

Required.  String.  The name or identifier of an existing block definition.

Returns

Array

An array of strings identifying the objects that make up a block definition if successful.

Null

If not successful, or on error.

Example

Dim strBlock, arrObjects, strObject

strBlock = Rhino.GetString("Block name to list identifiers")

If Rhino.IsBlock(strBlock) Then

arrObjects = Rhino.BlockObjects(strBlock)

If IsArray(arrObjects) Then

For Each strObject in arrObjects

Rhino.Print strObject

Next

End If

End If

Also See

BlockNames

BlockObjectCount

IsBlock