ChangeCurveDegree

Changes the degree of a curve object. For more information see the Rhino help file for the ChangeDegree command.

Syntax

Rhino.ChangeCurveDegree (strObject, intDegree [, blnDeformable])

Parameters

strObject

Required.  String.  The object's identifier.

intDegree

Required.  Number.  The new degree.

blnDeformable

Required.  Number.  If True, and the degree of the curve is different from the requested degree, the new curve  has simple interior knots.  If False, and the degree of the curve is LESS than the requested degree, the new curve will have exactly the same geometry and parameterization as the original, but it will have knots of multiplicity = old multiplicity + new degree - old degree.  If the degree of the curve is GREATER than the requested degree, then the new curve will be an approximation of the original with simple knots. The default value is False.

Returns

Boolean

True of False indicating success or failure.

Null

On error.

Example

Dim strCurve, intDegree

strCurve = Rhino.GetObject("Select curve", 4)

If Not IsNull(strCurve) Then

  intDegree = Rhino.CurveDegree(strCurve) + 1

  Call Rhino.ChangeCurveDegree(strCurve, intDegree)

End If

Also See

IsCurve

CurveDegree