Returns the degree of a curve object.
Rhino.CurveDegree (strObject [, intIndex])
strObject |
Required. String. The object's identifier. |
intIndex |
Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query. |
Number |
The degree of the curve if successful. |
Null |
If not successful, or on error. |
Dim strObject, dblDegree
strObject = Rhino.GetObject("Select a curve")
If Rhino.IsCurve(strObject) Then
dblDegree = Rhino.CurveDegree(strObject)
Rhino.Print "Curve degree: " & CStr(dblDegree)
End If