CloseCurve

Closes an open curve object by making adjustments to the end points so that they meet at a point.

Syntax

Rhino.CloseCurve (strObject [, dblTolerance])

Parameters

strObject

Required.  String.  The object's identifier.

dblTolerance

Optional. Number.  The maximum allowable distance between start point and end point of the curve.  If omitted, the document's current absolute tolerance is used.

Returns

String

The identifier of the closed curve object if successful.

Null

If not successful, or on error.

Example

Const rhObjectCurve = 4

Dim strObject

strObject = Rhino.GetObject("Select curve", rhObjectCurve)

If Not Rhino.IsCurveClosed(strObject) And Rhino.IsCurveClosable(strObject) Then

Rhino.CloseCurve strObject

End If

Also See

IsCurveClosable

IsCurveClosed