IsCurveClosable

Decide if it makes sense to close off the curve by moving  the endpoint to the start based on start-end gap size and length of curve as approximated by chord defined by 6 points.

Syntax

Rhino.IsCurveClosable (strObject [, dblTolerance])

Parameters

strObject

Required.  String.  The object's identifier.

dblTolerance

Optional. Number.  The maximum allowable distance between start point and end point of the curve.  If omitted, the document's current absolute tolerance is used.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Const rhObjectCurve = 4

Dim strObject

strObject = Rhino.GetObject("Select curve", rhObjectCurve)

If Not Rhino.IsCurveClosed(strObject) And Rhino.IsCurveClosable(strObject) Then

Rhino.CloseCurve strObject

End If

Also See

CloseCurve

IsCurveClosed