Returns the domain of a curve object.
Rhino.CurveDomain (strObject [, intIndex])
strObject |
Required. String. The object's identifier. |
intIndex |
Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query. |
Array |
The domain of the curve if successful. |
Null |
If not successful, or on error. |
Dim strObject, arrDomain
strObject = Rhino.GetObject("Select a curve")
If Rhino.IsCurve(strObject) Then
arrDomain = Rhino.CurveDomain(strObject)
Rhino.Print "Curve domain: " & CStr(arrDomain(0)) & " to " & CStr(arrDomain(1))
End If