Returns the minimum and maximum deviation between two curve objects. For more information on curve deviation, see the Rhino help file for the CrvDeviation command.
Rhino.CurveDeviation (strCurveA, strCurveB)
strCurveA |
Required. String. The identifier of the first curve object. |
strCurveB |
Required. String. The identifier of the second curve object. |
Array |
An array of numbers identifying the minimum and maximum deviation between the two curves if successful.
|
|||||||||||||||||||||
Null |
On error or if no intervals of overlap were found. |
Dim strCurveA, strCurveB, arrDeviation
strCurveA = Rhino.GetObject("Select first curve to test", 4)
strCurveB = Rhino.GetObject("Select second curve to test", 4)
arrDeviation = Rhino.CurveDeviation(strCurveA, strCurveB)
If IsArray(arrDeviation) Then
Rhino.Print "Minimum deviation = " & CStr(arrDeviation(5))
Rhino.Print "Maximum deviation = " & CStr(arrDeviation(2))
End If