Returns the knot count of a curve object.
Rhino.CurveKnotCount (strObject [, intIndex])
strObject |
Required. String. The object's identifier. |
intIndex |
Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query. |
Number |
The number of knots if successful. |
Null |
If not successful, or on error. |
Dim strObject, intCount
strObject = Rhino.GetObject("Select a curve")
If Rhino.IsCurve(strObject) Then
intCount = Rhino.CurveKnotCount(strObject)
Rhino.Print "Curve knot count: " & CStr(intCount)
End If