Returns the control points count of a curve object.
Rhino.CurvePointCount (strObject [, intIndex])
strObject |
Required. String. The object's identifier. |
intIndex |
Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query. |
Number |
The number of control points if successful. |
Null |
If not successful, or on error. |
Dim strObject, intCount
strObject = Rhino.GetObject("Select a curve")
If Rhino.IsCurve(strObject) Then
intCount = Rhino.CurvePointCount(strObject)
Rhino.Print "Curve point count: " & CStr(intCount)
End If