Returns the knots, or knot vector, of a curve object.
Rhino.CurveKnots (strObject [, intIndex])
strObject |
Required. String. The object's identifier. |
intIndex |
Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query. |
Array |
The knot values of the curve if successful. |
Null |
If not successful, or on error. |
Dim strObject, arrKnots, dblKnot
strObject = Rhino.GetObject("Select a curve")
If Rhino.IsCurve(strObject) Then
arrKnots = Rhino.CurveKnots(strObject)
If IsArray(arrKnots) Then
For Each dblKnot In arrKnots
Rhino.Print "Curve knot value: " & CStr(dblKnot)
Next
End If
End If