EllipseFoci

Returns the foci points of an elliptical-shaped curve object.

Syntax

Rhino.EllipseFoci (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Array

An array of 3-D points identifying the foci of the ellipse if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select ellipse")

If Rhino.IsEllipse(strObject) Then

Rhino.AddPoints Rhino.EllipseFoci(strObject)

End If

Also See

IsEllipse

EllipseCenterPoint

EllipseFocalDistance

EllipseQuadPoints