EllipseFocalDistance

Returns the distance from the center of an elliptical-shaped curve object to a focus.

Syntax

Rhino.EllipseFocalDistance (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Double

The distance if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select ellipse")

If Rhino.IsEllipse(strObject) Then

MsgBox Rhino.EllipseFocalDistance(strObject)

End If

Also See

IsEllipse

EllipseCenterPoint

EllipseFoci

EllipseQuadPoints