IsEllipticalArc

Verifies an object is an elliptical-shaped arc curve object.

Syntax

Rhino.IsEllipticalArc (strObject [, intIndex)

Parameters

strObject

Required.  String.  The object's identifier.

intIndex

Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select an elliptical arc")

If Rhino.IsEllipticalArc(strObject) Then

Rhino.Print "The object is an elliptical arc."

Else

Rhino.Print "The object is not an elliptical arc."

End If

Also See

EllipseCenterPoint

EllipseQuadPoints

IsEllipse