IsPolyline

Verifies an object is a polyline curve object.

Syntax

Rhino.IsPolyline (strObject [, intIndex])

Parameters

strObject

Required.  String.  The object's identifier.

intIndex

Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a polyline")

If Rhino.IsPolyline(strObject) Then

Rhino.Print "The object is a polyline."

Else

Rhino.Print "The object is not a polyline."

End If

Also See

IsPolyline

PolylineVertices