ParentDimStyle

Returns the name of a child dimension style's parent dimension style.  A child dimension styles is created when a dimension style, assigned to a dimension object, is overridden.

Syntax

Rhino.ParentDimStyle (strDimStyle)

Parameters

strDimStyle

Required.  String.  The name of an existing child dimension style.

Returns

String

The name of a child dimension style's parent dimension style if successful.

Null

If the dimension style does not have a parent, or on error.

Example

Dim strDimStyle

strDimStyle = Rhino.GetString("Dimension style to test")

If Rhino.IsDimStyle(strDimStyle) Then

  If Rhino.IsDimStyleChild(strDimStyle) Then

    Rhino.Print Rhino.ParentDimStyle(strDimStyle)

  Else

    Rhino.Print "The dimension style is not a child."

  End If

Else

  Rhino.Print "The dimension style does not exist."

End If

Also See

IsDimStyle

IsDimStyleChild