DocumentInfo

Returns summary information about a saved document (3dm).

Syntax

Rhino.DocumentInfo ([strFileName])

Parameters

strFileName

Optional.  String.  The file name of the document to query. Of omitted, the currently loaded document will be queried as long as it has been saved to disk.

Returns

Array

An array of document if successful. The array will contain the following information:

Element

Description

0

String. The file name

1

Number. The file version

2

String. General comments and notes useful to McNeel Technical Support.

3

String. The name of the user who created the document

4

Date. The date the document was created

5

String. The name of the user who last edited the document.

6

Date. The date the document was last saved

7

Number. The revision count.

8

String. The application that last saved the document.

9

String. The web site, or URL, of the application that last saved the document.

10

String. Other details about the application that last saved the document.

11

Number. The model unit system.

Null

If not successful, or on error.

Example

Sub TestDocumentInfo

  Dim strFile, arrInfo, i

  strFile = Rhino.OpenFileName("Open", "Rhino Model (*.3dm)|*.3dm||")

  If IsNull(strFile) Then Exit Sub

  arrInfo = Rhino.DocumentInfo(strFile)

  If IsNull(arrInfo) Then Exit Sub

  Rhino.ClearCommandHistory

  For i = 0 to UBound(arrInfo)

    Rhino.Print arrInfo(i)

  Next

End Sub

Also See

DocumentName

DocumentPath