IsKnotVectorUniform

Verifies that a knot vector is uniform. This method works either curve or surface knots.

For more information on knots, see RhinoScript Fundamentals.

Syntax

Rhino.IsKnotVectorUniform (intDegree, intCVCount, arKnots)

Parameters

intDegree

Required.  Number.  The degree.

intCVCount

Required.  Number.  The number of control points.

arrKnots

Required.  Array.  The knot vector.

Returns

Boolean

True if successful, False otherwise.

Null

On error.

Example

Dim strCurve, intDegree, intCVCount, arrKnots, blnResult

strCurve = Rhino.GetObject("Select curve", 4)

If Not IsNull(strCurve) Then

  intDegree = Rhino.CurveDegree(strCurve)

  intCVCount = Rhino.CurvePointCount(strCurve)

  arrKnots = Rhino.CurveKnots(strCurve)

  blnResult = Rhino.IsKnotVectorUniform(intDegree, intCVCount, arrKnots)

  If blnResult = True Then

    Rhino.Print "The knot vector is uniform."

  Else

    Rhino.Print "The knot vector is not uniform.

  End If

End If

Also See

IsKnotVectorClamped

IsKnotVectorPeriodic

KnotVectorHasBezierSpans

KnotVectorStyle