KnotVectorStyle

Returns the style of a knot vector. This method works either curve or surface knots.

For more information on knots, see RhinoScript Fundamentals.

Syntax

Rhino.KnotVectorStyle (intDegree, intCVCount, arKnots)

Parameters

intDegree

Required.  Number.  The degree.

intCVCount

Required.  Number.  The number of control points.

arrKnots

Required.  Array.  The knot vector.

Returns

Number

A number identifying the knot style if successful. The possible knot styles are:

Value

Description

0

Unknown knot style.

1

Uniform knots (ends not clamped).

2

Uniform knots (clamped ends, degree >= 2).

3

All internal knots have full multiplicity.

4

Clamped end knots (with at least 1 interior non-uniform knot).

5

Known to be none of the above.

Null

If not successful, or on error.

Example

Dim strCurve, intDegree, intCVCount, arrKnots, intStyle

strCurve = Rhino.GetObject("Select curve", 4)

If Not IsNull(strCurve) Then

  intDegree = Rhino.CurveDegree(strCurve)

  intCVCount = Rhino.CurvePointCount(strCurve)

  arrKnots = Rhino.CurveKnots(strCurve)

  intStyle = Rhino.KnotVectorStyle(intDegree, intCVCount, arrKnots)

End If

Also See

IsKnotVectorClamped

IsKnotVectorPeriodic

IsKnotVectorUniform

KnotVectorHasBezierSpans