Home > RhinoScript Methods > Material Methods > MaterialCount

Show Navigation Component

MaterialCount

Returns the number of materials in the document.

Syntax

Rhino.MaterialCount ()

Parameters

None.

Returns

Number

The number of materials in the document.

Example

Dim intCount

intCount = Rhino.MaterialCount

Rhino.Print "There are " & CStr(intCount) & " materials."

Also See

MaterialId

MaterialIds

MaterialIndex