DeleteMeshFace

Deletes one or more faces from a mesh object.

Syntax

Rhino.DeleteMeshFace (strObject, intFaceIndex)

Rhino.DeleteMeshFace (strObject, arrFaceIndices)

Parameters

strObject

Required. String. The object's identifier.

intFaceIndex

Required. Number. The index of the face to delete.

arrFaceIndices

Required. Number. The indices of the faces to delete.

Returns

Number

The number of faces deleted from the mesh object if successful.

Null

If not successful, or on error.

Example

Dim strMesh, arrIndices

strMesh = Rhino.GetObject("Select mesh", 32)

If Not IsNull(strMesh) Then

  arrIndices = Rhino.GetMeshFaces(strMesh)

  If IsArray(arrIndices) Then

    Call Rhino.DeleteMeshFace(strMesh, arrIndices)

  End If

End If

Also See

IsMesh

GetMeshFaces

MeshFaceCount

MeshFaces

MeshFaceVertices