ExplodeMeshes

Explodes a mesh object, or mesh objects,  into submeshes.  A submesh is a collection of mesh faces that are contained within a closed loop of unwelded mesh edges.  Unwelded mesh edges are edges where the mesh faces that share the edge have unique mesh vertices (not mesh topology vertices) at both ends of the edge.

Syntax

Rhino.ExplodeMeshes (strObject [, blnDelete])

Rhino.ExplodeMeshes (arrObjects [, blnDelete])

Parameters

strObject

Required.  String.  The identifier of the mesh object to explode.

arrObjects

Required.  Array.   An array of strings identifying the mesh objects to explode.

blnDelete

Optional.  Boolean.  Delete input objects after exploding.  The default is not to delete objects (False).

Returns

Array

An array of strings identifying the newly created mesh objects if successful.

Null

If not successful, or on error.

Example

Const rhObjectMesh = 32

Dim strObject

strObject = Rhino.GetObject("Select mesh to explode", rhObjectMesh)

If Rhino.IsMesh(strObject) Then

Rhino.ExplodeMeshes strObject

End If

Also See

IsMesh