IsPointOnMesh

Verifies that a point is on a mesh.

Syntax

Rhino.IsPointOnMesh (strObject, arrPoint [, dblTolerance])

Parameters

strObject

Required. String. The object's identifier.

arrPoint

Required.  Array.  The test, or sampling, point.

dblTolerance

Optional.  Number.  A tolerance to test against. Of omitted, Rhino's internal zero tolerance is used.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject, arrPoint

strObject = Rhino.GetObject("Select a mesh")

If Rhino.IsMesh(strObject) Then

arrPoint = Rhino.GetPointOnMesh(strObject, "Pick a test point")

If IsArray(arrPoint) Then

If Rhino.IsPointOnMesh(strObject, arrPoint) Then

Rhino.Print "The point is on the mesh"

Else

Rhino.Print "The point is not on the mesh"

End If

End If

End If

Also See

IsMesh

MeshClosestPoint