IsObjectLocked

Verifies that an object is locked.  Locked objects are visible and can be snapped to, but they cannot be selected.

It is possible for an object to be unlocked, but reside on a layer that is locked. In such case, the object will still report as unlocked.

Syntax

Rhino.IsObjectLocked (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

True

The object is locked.

False

The object is not locked.

Null

On error.

Example

Dim strObject

'Do something here...

If Rhino.IsObjectLocked(strObject) Then

Rhino.Print "The object is locked."

Else

Rhino.Print "The object is not locked."

End If

Also See

IsObject

IsObjectHidden

IsObjectInGroup

IsObjectNormal

IsObjectReference

IsObjectSelectable

IsObjectSelected

IsObjectSolid