IsObjectNormal

Verifies that an object is normal.  Normal objects are objects that are neither hidden nor locked.  Normal objects are visible, can be snapped to, and can be selected.

It is possible for an object to be normal but reside on a layer that is either hidden or lock. In such case, the object will report as normal.

Syntax

Rhino.IsObjectNormal (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

True

The object is normal.

False

The object is not normal.

Null

On error.

Example

Dim strObject

'Do something here...

If Rhino.IsObjectNormal(strObject) Then

Rhino.Print "The object is normal."

Else

Rhino.Print "The object is not normal."

End If

Also See

IsObject

IsObjectHidden

IsObjectInGroup

IsObjectLocked

IsObjectReference

IsObjectSelectable

IsObjectSelected

IsObjectSolid